Installation du module PHP Quanta

Le module PHP Quanta se présente sous la forme d'une extension PHP et vous permettra de remonter des informations concernant le temps d'exécution de chaque partie de votre CMS.

Google_Chrome_2019-03-01_14-49-48_2x.png

Prérequis:

Avant d'installer le module PHP Quanta sur votre infrastructure, vous devez avoir installé l'agent Quanta.
En effet, le module PHP utilise l'agent Quanta pour renvoyer ses données vers nos serveurs.
Le module PHP est à installer sur chaque serveur exécutant votre application PHP.


 

Dans cet article

 

Installer le module PHP Quanta pour Debian:

Il vous faudra avoir ajouté les dépôts Quanta, vous avez déjà dû le faire lors de l'installation de l'agent.

En fonction de votre version de PHP, il vous faudra installer le package correspondant:

  • Pour PHP 5.3:
    apt-get install php53-quanta-mon
  • Pour PHP 5.4:
    apt-get install php54-quanta-mon
  • Pour PHP 5.5:
    apt-get install php55-quanta-mon
  • Pour PHP 5.6:
    apt-get install php56-quanta-mon
  • Pour PHP 7.0:
    apt-get install php70-quanta-mon
  • Pour PHP 7.1:
    apt-get install php71-quanta-mon
  • Pour PHP 7.2:
    apt-get install php72-quanta-mon
  • Pour PHP 7.3:
    apt-get install php73-quanta-mon

 

À partir de PHP 5.4, vous devrez également activer l'extension avec la commande

php5enmod quanta_mon 

La commande est changée à partir de PHP7 en:

phpenmod quanta_mon

 

Installer le module PHP  Quanta pour CentOS / RedHat:

Il vous faudra avoir ajouté les dépôts Quanta, vous avez déjà dû le faire lors de l'installation de l'agent.

En fonction de votre version de PHP, il vous faudra installer le package correspondant:

  • Pour PHP 5.3:
    yum install php53-quanta-mon
  • Pour PHP 5.4:
    yum install php54-quanta-mon
  • Pour PHP 5.5:
    yum install php55-quanta-mon
  • Pour PHP 5.6:
    yum install php56-quanta-mon
  • Pour PHP 7.0:
    yum install php70-quanta-mon
  • Pour PHP 7.1:
    yum install php71-quanta-mon
  • Pour PHP 7.2:
    yum install php72-quanta-mon

 

À partir de PHP 5.4, vous devrez également activer l'extension avec la commande

php5enmod quanta_mon 

La commande est changée à partir de PHP7 en:

phpenmod quanta_mon

 

Installer PHP pour les autres OS:

Nous ne supportons pas officiellement de packages pour les autres OS,
Néanmoins vous pouvez compiler vous-même le module, les sources sont disponibles sur Github :
https://github.com/quanta-computing/quanta-php-module

Optionnel: Configurez L'URL de votre backoffice si vous utilisez Magento

Si vous utilisez Magento et qu'une URL customisée est utilisée pour accéder au backoffice Magento (c'est-à-dire une URL qui ne commence pas par "/admin/")

Il est nécessaire de modifier la configuration du module afin que les évènements de type "Magento" remontent correctement dans Quanta.

Ce fichier se trouve généralement dans:

/etc/php5/mods-available/quanta_mon.ini 

pour Debian et

/etc/php.d/quanta_mon.ini

pour Centos

Cela peut néanmoins varier en fonction de votre installation PHP.

Par exemple, si l'URL de votre backoffice est"http://admin.monsite.com/admin_123456/" vous devez entrer le paramètre suivant:

quanta_mon.admin_url="/admin_123456/"

 

Redémarrage du serveur web

Après l'installation du module, il vous faudra redémarrer le service web pour que l'extension PHP soit chargée et activée.

  • Par exemple si vous utilisez Apache sous Debian : 
    /etc/init.d/apache2 restart
  • Si vous utilisez PHP-FPM, la commande sera par exemple: 
    /etc/init.d/php5-fpm restart

Vérification du bon fonctionnement

Lorsque tout est installé, et que le scénario de navigation web est créé dans Quanta, allez dans le menu Scénario Web, puis cliquez sur "+ détails" dans la légende sur l'une des pages nécessitant l'exécution de PHP (exemple : une page Panier qui n'est généralement jamais en cache).

Vous devriez alors voir l'onglet "Application" (autrement cet onglet est grisé) des informations concernant le temps passé dans PHP comme ceci :
PHP2.png

Dans le cas d'utilisation d'un CMS Magento (v1 ou 2) ou de la plateforme OroCommerce, le code couleur est différent, exemple ici sur OroCommerce :
PHP3.png

 

Et voilà vous êtes prêt à utiliser Quanta!

Quanta_doodle.png

Les versions PHP supportées par Quanta

 

CentOS 7:

  • 7.2 (module version: 1.3.0)
  • 7.1 (module version: 1.3.0)
  • 7.0 (module version: 1.3.0)
  • 5.6 (module version: 1.2.2)
  • 5.5 (module version: 1.2.2)
  • 5.4 (module version: 1.2.2)

CentOS 6:

  • 5.4 (module version: 1.2.2)
  • 5.5 (module version: 1.2.2)
  • 5.6 (module version: 1.2.2)

Debian Jessie:

  • 5.6 (module version: 1.2.2)
  • 7.0 (module version: 1.3.0)
  • 7.1 (module version: 1.3.0)
  • 7.2 (module version: 1.3.0)
  • 7.3 (module version: 1.3.0)

Debian Stretch

  • 7.0 (module version: 1.3.1)
  • 7.1 (module version: 1.3.1)
  • 7.2 (module version: 1.3.1)
  • 7.3 (module version: 1.3.1)
Cet article vous a-t-il été utile ?
Utilisateurs qui ont trouvé cela utile : 0 sur 0
Vous avez d’autres questions ? Envoyer une demande

0 Commentaires

Cet article n'accepte pas de commentaires.